マビノギ知識王

ウィンドウ、文字などが描画されません
yugu 08/07/24 21:58

本日、7/24のアップデートより、ウィンドウと文字が描画されなくなりました。
3日前までは正常にログインできていました。
3D部分、キャラクターやフィールド、ドロップされたアイテムに関しては全く問題ありません。
ウィンドウ、文字、インベントリのアイテムなどは表示されません。
ただ、キャラクターとフィールドが存在するだけです。
他キャラも見えます。ただ、名前やギルド名などは表示されません。
ウィンドウと文字が表示されないだけで、ログインが可能なことも確認しました。
(ID,Passの入力も見えず、ボタンも見えずですが、まぁβからの習慣でどうとでも)
終了も、相変わらずウィンドウなどが見えないだけで、位置を予想して押せば終了も可能です。
 
再インストールも試してみましたが、結果は変わらず。
自分なりに考えられる原因としては、一昨日にMicrosoft DirectX SDK (March 2008)をインストールしたことくらいなのですが、これが原因なのか、今日のアップデートが問題なのかがわかりません。
ただ、今日特に同じような話題が見受けられないことから、前者なのかとは思います。
もし前者の場合、どうすれば元に戻せるのかを教えて頂きたいと思います。


スペックを明記しておきます。
(※25日0:55、グラフィックドライバ更新)

 "システム" タブ
  ・オペレーティング システム : Microsoft Windows XP Home Edition (5.1, ビルド 2600)
  ・言語 : 日本語 (地域設定:日本語)
  ・システム製造元 : Sony Corporation
  ・システムモデル : VGC-RC51
  ・プロセッサ : Intel(R) Pentium(R) D CPU 2.80GHz (2 CPUs)
  ・メモリ : 1022 RAM
  ・DirectX バージョン : DirectX 9.0c (4.09.0000.0904)

  "ディスプレイ" タブ
  ・名前 : NVIDIA GeForce 6600
  ・チップの種類 : GeForce 6600
  ・メモリ合計 : 256.0 MB
  ・ディスプレイのモード : 1280 x 1024 (32 bit) (60Hz)
  ・メインドライバ : nv4_disp.dll
  ・バージョン : 6.14.0011.7519 (英語)
  ・日付 : 2008/05/16 14:01:00
  ・DirectDraw アクセラレータ : 使用可能
  ・Direct3D アクセラレータ : 使用可能
  ・AGP テクスチャ アクセラレータ : 使用可能

  "サウンド" タブ
  ・名前 : SigmaTel Audio
  ・ドライバ : sthda.sys
  ・バージョン : 5.10.5010.0000 (英語)
  ・日付 : 2006/03/31 17:27:06
 
追記:
IEのバージョン : 6.0.2900.2180 (Internet Explorer 6 SP2)
 
それから、ログインが出来るので(無理やりですが)中で何か原因を探れないかと思い、とりあえずログインしてみました。
すると、ダンバ広場であることに気付きました。
カメラが特定角度、特定方向にあるときにだけ、全てのウィンドウが見えるようになりました。見えている時は、ほぼ全て問題なく表示されることを確認しました。
このカメラの位置に何か法則性がないかと回してみると、どうも時刻によって少しずつ動いてる様子。
そこから、もしかすると太陽が影響しているのではないかと思い、環境設定で光源設定のチェックをはずしてみたところ、正常に表示されるようになりました。
 
ですが、ダンバ←→銀行のようにマップ移動を行うと、画面切り替えの時に全体がチカチカ点滅します。
これは、ウルラ←→イリアや、ケルラベースキャンプ←→ケルラ港では発生しませんでした。
 
他のオプションも弄ってみましたが、光源効果以外は正常に動作している、と思われます。
全てに対してOnOffで画面切り替え効果のチェックをしてみましたが、どう設定されていても必ず点滅は発生するようです。

カセトノテ改 ウィンドウ・文字はブラウザ使ってたような気がするから・・・IEのバージョン情報も必要かも。 08/07/24 22:34
不破くん システムの復元 で、Microsoft DirectX SDK をインストールする前の状態に戻せませんかね? 08/07/25 09:27
芽姫 DirectX SDKのメニューにリリースDLLを使うか、デバッグDLLを使うかと言うのがなかったっけか… だいぶ前の事なのでうろ覚えです。 08/07/25 12:33
yugu 様の答え
yugu 08/07/25 15:05

皆さんコメントありがとうございます。
芽姫さんのコメントから、debugとretailと選択出来、開発する時はdebugで行い、配布用を作るときにretailにするというセオリーに則り、debugを選択していたことを思い出しました。
retailに変えてから確認したところ、光源効果、画面切り替え時の点滅が正常になったことを確認しました。
結局はこの設定だけの問題だったようです…お騒がせしました。
そして、ありがとうございました。

答えの出所 コメントより
件名 評価 閲覧数

インストール ,起動 手動アップデートパッチについて

+6
13302

インストール ,起動 アンインストーラの場所

+3
3381

インストール ,起動 グラフィックカードのことについて・・・

+4
5362

インストール ,起動 またINできなくなりました

+1
4364

インストール ,起動 セキュリティーレベル

+20
6162

インストール ,起動 XP SP3の導入

+4
4157

インストール ,起動 ログイン中ですから進みません・・・

+2
3717

インストール ,起動 破廉恥なバグ?

+4
4509

インストール ,起動 起動しない…orz

+6
5002

インストール ,起動 グラフィックカード

+2
4052

インストール ,起動 このスペックで今後プレイ可能?

+4
3400

インストール ,起動 前にインストールしたマビノギのデータ復活方法教えてください

+4
4484

インストール ,起動 サブディスプレイにてクライアント使用

+2
9086

インストール ,起動 VISTAでのActiveX削除について

5837

インストール ,起動 McAfee使用中の方へ「adware-baidu」について

+5
13743

インストール ,起動 マビノギノインストール

3395

インストール ,起動 「ログイン中です」という画面から動きません

+1
4019

インストール ,起動 Vistaで保護者機能が有効な時にアップデートできない

+2
6183

インストール ,起動 ウィンドウ、文字などが描画されません

+3
3681

インストール ,起動 スペックについての質問

+2
4043